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AVANTHI INSTITUTE OF ENGINEERING & TECHNOLOGY

AIET started in the year 1999 and offers various courses at Engineering and
PG level. The college is providing with rooms, computer centre, laboratories
and seminar hall with audio-visual equipments. Industry Institute interaction is
conducted regularly to emphasize on the latest trends in the present market.

It is very near to Narsipatnam. Frequent bus facilities are available
both from and to Visakhapatnam and Narsipatnam. Very safe and secure
hostel facility is available for Girl students. These are the additional facilities
besides excellent academic atmosphere in the college campus.

DEPARTMENT OF COMPUTER SCIENCE ENGINEERING

The Computer Science & Engineering department was established with
B.Tech Program in 1999 with intake of 60 students and this was increased to
120 students in 2007 and increased to 180 students in 2012. The Post graduate
Program M.Tech with C.S.E was started in 2005 with intake of 18 Students
and this was increased to 24 students in 2012. The Computer Science &
Engineering department was accredited by NBA in 2009 and 2014.
Department mission is to be Instrumental in the field of computer science &



Avanthi Institute of Engineering And Technology

engineering by providing high quality education and continues improvement
process of the program. The department has full fledged faculty with four
professors with Ph.D and 40 staff members with experience in teaching and
industry, which leads the skill students to get employment in the market. . The
department encourages the faculty members and the students to participate
paper presentations, workshops and National, International
conferences and research activities. The department is well equipped
laboratories and the computers have sophisticated development software tools.
The department provides training to its students in advanced technologies like
JAVA, WEB TECHNOLOGIES,.NET, PHP, Data Warehousing, Data Mining
tools and Data storage systems as a supplement to the curriculum to enhance
the employability of students. Our faculty members are the members of
Computer Society of India, ISTE, IEEE.

seminars,

ABOUT COURSE

Google Developers (previously Google Code) is Google's site for software
development tools and platforms, application programming interfaces (APIs),
and technical resources. The site contains documentation on using Google
developer tools and APIs—including discussion groups and blogs for
developers using Google's developer products.

The Android Developer Fundamentals course was created by the Google
Developers Training team. To take the course, you must have experience with
the Java programming language.

TOPICS TO BE COVERED

DAY 1 Introduction to the WebDriver & Comparison with Selenium RC
DAY 2 Gain an understanding of the Architecture of selenium Webdriver
DAY 3 Examine the Enhancement of a script using Selenium IDE

DAY 4  Describe how to Handling Ajax Components

DAY 5 Explain Scope of Automation

DAY 6  Become familiar with the Testing at different Levels

For Registration please contact Mr.V.Trindah , Assistant Professor,
CSE

CHIEF PATRON PATRON CHAIRMAN
Smt. M. Gnaneswari, Dr. CP V N J Mohan Rao Dr. G. Satyanarayana
President Principal, Head of the Department

Avanthi Institute Of Engineering And Technology

Computer Science & Engineering


https://en.wikipedia.org/wiki/Google
https://en.wikipedia.org/wiki/Software_development
https://en.wikipedia.org/wiki/Software_development
https://en.wikipedia.org/wiki/Application_programming_interface
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DEPARTMENT OF COMPUTER SCIENCE AND ENGINEERING

Dt: 28" Aug, 2017.

CIRCULAR

On behalf of the Department of Computer Science and Engineering, AIET is conducting
one week certificate course on “Google Android Developer” during 4™ Sept 2017 to 9" Sept
2017 for all the students of II Year of Computer Science and Engineering Department. I advise
to all the students of I year CSE to enroll your details for above course. For more details, you
may consult Course Coordinator Mr.V.Trinadh, Assistant Professor, CSE Department.

Resource Persons:

1. Dr.A.M.Sowjanya
Assistant Professor
Computer Science Engineering
Andhra University
Visakhapatnam

2.Dr.K.Jayasri
Assistant Professor
Computer Science Engineering

Vignan’s Institute of Engineering for Women

©n eJeyenes

G.Satyanarayana
Head of the Department
Computer Science & Engineering
Avanthi‘institute of Engg & Technaiagy
Copy to: Principal, AIET Tamaram, Makavarapalem Md
Visakhapatnam District, Pin-531113
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AVANTHI INSTITUTE OF ENGINEERING AND TECHNQLOGY
(Approved by AICTE, Permanently Affiliated to JNT University Kakinada, .
Accredited By NAAC and Recognized under 2(f) &12 (b) by UGC, New Delhi)
Tamaram, Makavarapalem, Narsipatnam (RD), Visakhapatnam-531113

Google Android Developer
Duration: 4-09-2017 to 9-09-2017
SYLLABUS

Day 1: Introduction to the Web Driver & Comparison with Selenium RC

Day 2:Gain an understanding of the Architecture of selenium Web driver

Day 3: Examine the Enhancement of a script using Selenium IDE

Day 4: Describe how to Handling Ajax Components

Day S: Explain Scope of Automation

Day 6: Become familiar with the Testing at different Levels

g

Coordinator

Mr.V.Trinadh
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G.Satyanarayana
Head Of the Department

Computer Science and Engineering
Avanthi'institute of Engg & Technoiagy
Tamaram, Makavarapalem Md
Visakhapatnam District, Pin-531113



Day 1(4-9-2017)

9.00AM-1.00 P.M

1.O0ADM-2.00P.M

AVANTHI INSTITUTE OF ENGINEERING AND TECHNOLOGY
, (Approved by AICTE, Permanently Affiliated to JNT University Kakinada,
s Accredited By NAAC and Recognized under 2(f) &12 (b) by UGC, New Delhi)

: Tamaram, Makavarapalem, Narsipatnam (RD), Visakhapatnam-531113

Google Android Developer
Duration: 4-09-2017 to 9-09-2017

Schedule

:Introduction to the WebDriver

: Lunch

2.00P.M — 4.00P.M: Comparison with Selenium RC

Day 2(5-9-2017)
9.00AM - 1.00P.M
1.00A.M-2.00P.M

2.00P.M - 4.00P.M
Dav 3(6-9-201
9.00AM - 1.00 P.M
1.00AM-2.00P.M
2.00P.M - 4.00P.M

Day 4(7-9-201
9.00AM-1.00 P.M

1.00A.M-2.00P.M
2.00P.M - 4.00P.M
Dav 5(8-9-2017)
9.00A.M - 1.00 P.M

1.00A.M-2.00P.M
2.00P.M - 4.00P.M

: Gain an understanding of the Architecture of selenium Webdriver

: Lunch

: Gain an understanding of the Architecture of selenium Webdriver

: Examine the Enhancement of a script using Selenium IDE

: Lunch

: Examine the Enhancement of a script using Selenium IDE

: Describe how to Handling Ajax Components

: Lunch

: Describe how to Handling Ajax Components

: Explain Scope of Automation
: Lunch
: Explain Scope of Automation



Day 6(9-9-2017)
9.00AM - 1.00 P.M

1.00A.M-2.00P.M
2.00P.M - 4.00P.M

Mr.V.Trinadh
Coordinator

+ Become famuliar with the Testing at different Levels

: Lunch

¢ Become familiar with the Testing at different Levels

CvStipane deyane
G. Satyanarayana

Head of the Department
Computer Science Engineering
Avanthi‘institute of Engg & Technaiogy
Tamaram, Makavarapalem Md
Visakhapatnam District, Pin-531113
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DEPARTMENT OF COMPUTER SCIENCE AND ENGINEERING

Google Andriod Developer

Dated: 4/9/2017 To 9/9/2017

1 B.Tech STUDENTS ATTENDANCE LIST

ROLL.NO

NAME OF THE STUDENT Day 1 Day 2 Da 3 Day 4 Day 5 Day 6

1 16811A0501 |ABRAHAM SHARON LEELA ROSILYN | _/ S & I 4 S

2 16811A0502 | ADHIKARI SWATHI ji ~ -~/ /S 2 A
3 16811A0503 |AKULA LAVANYA < s/ 7 >4 /s 4
4 16811A0504 |ANNAPAREDDY DALI DEEPIKA v 4 S o W4 v
5 16811A0505 |BADIREDDY SURENDRA v v J/ 7 7/ &
6 16811A0506 |BANDARU SARASWATHI v “ ol ol v/ J
7 16811A0507 [BEESETTI YUVA KIRAN SAI v 4 v 7 J v/
8 16811A0508 [BHEEMISETTY LAVANYA P4 o i F 4 7
9 16811A0509 [BHEEMISETTY RAMYA o f J/ T 7 4
10 | 16811A0510 |BOBBADI SIVA GOWRI NEELIMA v f Wi Wi v v/
11 16811A0511 [BODDEDA SIVA GOPI LAKSHMI v 7 / T X, ¥4
12 16811A0512 [BODDU JAYA MADHURI J / 7 & ol 4
13 16811A0513 [BOLEM SAIKUMAR / L L / o v
14 16811A0514 |BOTCHA DURGA ¥4 Wi Vi b 7 7
15 16811A0515 [DARAKONDA VASANTHA LAXMI v o / J/ " i o
16 16811A0516 DEVARAPALLI NAGA KAIVALYA / i / s Vi F
17 16811A0517 DEVARASETTI JAGADESWAR RAO oL / / 4 Y o

DHARMALA SAI GURUDATTA 7 a ",

18 | 168110518 [ 1o v 7 el )

19 | 16811A0519 [DIMILI RAGHURAM v J o " § 7 P
20 | 16811A0520 [DODDI HARIKA RAMANI v / v v 7 v
21| 16811A0521 DWARAPUREDDY ANITHA / i v / 7 ‘




ELLAPU UPENDRA KUMAR NOOKA

b ] -
22| 1es11A0s22 o C v v 7 L V|
23 16811A0523 |GANDETI SRINIVASA RAO v > v i v /
24 | 16811A0524 |GANDIPADALA GANGADHAR 3 / v S J | 7
25 | 1681140525 |GANGALA SRAVANI 7 | 7 Cd v i
26 | 16811A0526 |GANGIREDDY GOUTHAM 7 oz & S / <
27 | 16811A0527 |GINNI JIYOTHISHMATHI 7 7 4 J Vi "
28 16811A0528 |GOGADA SATISH NAIDU v v »a o 7 </
29 | 16811A0529 |GORLE PADMA / 7 v, < / e
30 | 16811A0530 |[GUDIVADA EEPSITHA JAHNAVI o 7 v ” v/ /
31 16811A0531 |GUMMIDI INDRAVATHI v / v Wi v <
32 16811A0532 [JETTI HEMANTHI v < v S i S
33 16811A0533 [KAVULURI MANASA SRILAXMI v R v v/ o 7z
34 16811A0534 |[KILAPARTHI SOMESWARA RAO v v i v o v/
35 16811A0535 |KILLADA LEELA PRASAD v 7 4 o W o+
36 | 16811A0536 [KOLAGANI GIRISHMA w4 - ¥ J o v/
37 16811A0537 |[KONA VARMA =4 J 7 g 7
38 16811A0538 |[KOTIPALLI SWAMY v / o o i T
39 16811A0539 [KUNCHA GANGA BHAVANI v ol o % - i
40 16811A0540 [KUNDRAPU SIVAKRISHNA & W o i " T
41 16811A0541 [KUPIREDDY SRAVANI v / v v v S
42 16811A0542 |[KUPPILI SANDEEP KUMAR v W I v 7 v
LAKAMSANI DURGA SAI ANIL S ,
43 1681140543 1 0 0 RY / 4 S s P
44 16811A0544 [IMADEM UMADEVI il Wl X ¥ 7 S
45 16811A0545 [MALLA MRUDULANKITHA S ¥ i o ") 7
46 16811A0546 [MATSA BHAGYA LAKSHMI I v A J o
47 | 16811A0547 |MEDESETTI PAVANI il v v V4 < ~
48 | 16811A0548 [MIDATHANA SITARAMA RAJU X v v 7 s v
49 16811A0549 [MINDI SAI VENKATA SRIKANTH v f V v v Vv
S0 | 16811A0550 [MISRO MONALI e J J\/L v Pl 4 s
AD
P ERlLAGEST MODALAVALASA M s W " Y %

SAl




52| 16811A0552 [MOHAMMAD GULE AFSHA 4 JIA 1 717
53 | 16811A0553 [NADIPINTI DURGA MOHAN PRASAD | / / / v
54 16811A0554 INAGUBILLI SANTHOSHILAKSHMI J o/ / 7 1 __';-"“:___ +:_
55| 16811A0555 [NAKKA GANESHDURGA 7 7 7 1 7 | J1 < |
56 | 16811A0556 [NALLALA RAMU z / S W
57 [ 16811A0557 [NALLALA SATEESWARARAO < 1 ,_i. =
58 | 16811A0558 [PACHCHIKURA LIKITHA 7 E L g1 g1 v 1
59| 16811A0559 |PACHIGOLLA SRINIVASU 7 L1 v 1 71 A1 7.
60 | 16811A0560 |PANDE GIRINDHAR RAO il o v/ v va _-7:
61 | 16811A0561 |PAPPU KRUTHIKA 7 Vi v w4 v .
62 | 16811A0562 [PATCHIGOLLA LATHA A 7 / / 1 v/
63 | 16811A0563 |PATHALA PRASAD ” 4 i v Wi / e
64 | 16811A0564 [PATNANA KISAN KUMAR 7 7 o o 7 7
65 | 16811A0566 |PEDADA NINEESHA v v/ v o P [
66 | 16811A0567 |PEDIREDLA SUSMITHA ~ = A . 4.
67 | 16811A0568 |PERAPU VARA POORNIMA 7 7 7 7 il
68 | 16811A0569 |PITLA CHANDRIKA X "5 v A T
69 | 16811A0570 |PITTA HARISH S v e e e
70 | 16811A0571 |PITTA SUNIL KUMAR 7 7 v <
71| 16811A0572 |PRASADAM SIVA KRISHNA 7 7 7 7 "
72| 16811A0573 |PUDI GANESH < v v v/ - ]
73| 16811A0575 |RAPETI HEMANTH 7 v v ~ 1 X
74 | 16811A0576 |RAVI SRI RAM v v/ v i v /
75 | 16811A0577 |REDDY SRIKANTH v v v v v 4
76 | 16811A0578 |SALUMURI DILIP KUMAR v v v ’ v v

\é-'\ G Se i.ur Ye Y jarm

Coordinator HOD

Avanthi‘institute of Engg & Technoiagy

Tamaram, Makavarapalem Md
Visakhapatnam District, Pin-531113
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Department of Computer Science and Engineering

Dt:11-9-2017
Department of Computer Science and Engineering, Avanthi Institute of Engincering and
Technology had organized a certificate course on “Google Android Developer” during 4-9-2017
10 9-9-2017
We had Resource Person: Dr.A.M Sowjanya, Assistant professor, CSE, A.U, was explained
about Set up the Android development environment such as Stepl: Setup Java Development Kit
(JDK) we can download the JDK and install it, which is pretty easy. After that, you just have to
st PATH and JAVA HOME  variables to the folder where  you
have java and javac.setPATH=C:\jdk 1.6.0;%PATH%set JAVA_HOME=C:\jdk1.6.0 15 after
that Setup Eclipse IDE,next Setup Android Development Tools (ADT) Plugin next we have to

click on Help > Software Updates > Install New Software, next create android virtual device.

Next Resource person: Dr.K.Jayasri,Assistant professor,CSE,Vignan’s Institute of
Engincering for women, Duvvada was explained installation of Eclipse and Launch Android
AVD Manager from options Window > AVD Manager and click on New which will create a
successful Android Virtual Device.Now you need to build the application and to do this, Right
Click on your Android Project and select Android Tools->Export Signed Application Package. After
selecting the export button, select Create new keystore and it will take you to the location where
you want to save it, so give it a name and save it. Fill in all the required fields that are self-
explanatory and save it. You have successfully exported the apk file to your computer and you

can test the app it on your android device.

\‘HY Co Sy ¥Yferna

Coordinator Head of the Department
CSE
Avanthi'institute of Engg & Technoiogy
Tamaram, Makavarapalem Md
Visakhapatnam District, Pin-531113
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